Scheduled for March 15, 2024 at 11:00 PM – March 16, 2024 at 12:16 AM
Affects
Websites
Under maintenance from 11:00 PM to 12:16 AM
Kumpe3D
Under maintenance from 11:00 PM to 12:16 AM
Completed
March 16, 2024 at 12:16 AMCompleted
March 16, 2024 at 12:16 AMOur maintenance has been completed ahead of schedule.
In progress
March 15, 2024 at 11:00 PMIn progress
March 15, 2024 at 11:00 PMMaintenance is now in progress
Planned
March 15, 2024 at 11:00 PMPlanned
March 15, 2024 at 11:00 PMWe are planning for a scheduled maintenance on the kumpe3d.com website during that time Friday March 15th @ 8pm until Saturday March 16th @ 8pm. The Kumpe3D Website will be down during this maintenance period. No other websites will be affected.